# Contents

Contents ........................................................................................................................................... 3

Welcome to Axiom .......................................................................................................................... 9

Concepts ........................................................................................................................................... 10

Built for Collaboration ..................................................................................................................... 10

Requirements are Artifacts ........................................................................................................... 10

Templates Define Artifact Types .................................................................................................. 11

Axiom Helps You Manage Artifacts ............................................................................................... 12

Logging In ........................................................................................................................................ 13

Troubleshooting Connection Problems .......................................................................................... 13

Artifact Templates .......................................................................................................................... 15

Creating a Template ....................................................................................................................... 15

Creating Artifacts from Templates ................................................................................................. 15

Modifying a Template .................................................................................................................... 16

Locating Templates in the Artifact Explorer .................................................................................. 16

Working with Artifacts ................................................................................................................... 17

Creating a New Artifact .................................................................................................................. 17

Deleting Artifacts ........................................................................................................................... 17

Copying Artifacts ........................................................................................................................... 17

Moving Artifacts ............................................................................................................................. 17

Editing Artifacts ............................................................................................................................. 19

Attributes Editor ............................................................................................................................. 19

Modifying Attributes .................................................................................................................... 20

Content Editor ................................................................................................................................. 20

Adding Tables .................................................................................................................................. 21

Inserting Pictures ........................................................................................................................... 21

Inserting Hyperlinks ....................................................................................................................... 21
Artifact Collections .................................................................................................................. 23
Inserting Artifact Collections .................................................................................................. 23
Editing Embedded Artifacts ..................................................................................................... 25
Opening Embedded Artifacts .................................................................................................... 25
Securing Artifacts ..................................................................................................................... 26
Creating Microsoft Word Documents ......................................................................................... 27
Creating a Microsoft Office Dataset .......................................................................................... 27
Viewing Microsoft Office Datasets ........................................................................................... 27
Updating Datasets ..................................................................................................................... 28
Editing Datasets ........................................................................................................................ 28
Deleting Datasets ....................................................................................................................... 28
Using Axiom Collection Templates in Microsoft Word ............................................................... 29
Inserting Artifact Collection Templates .................................................................................... 29
Editing Artifact Collection Templates ....................................................................................... 30
Populating Documents with Axiom Artifacts .............................................................................. 31
Email Triggers ............................................................................................................................ 32
Creating Email Triggers ............................................................................................................ 32
Building User Interface Wireframes .......................................................................................... 34
Creating Wireframe Templates .................................................................................................. 34
Creating Wireframe Artifacts .................................................................................................... 35
Wireframe Perspective ............................................................................................................... 35
Using the Wireframe Editor ......................................................................................................... 36
Adding Components .................................................................................................................. 36
Moving and Aligning Components ............................................................................................ 36
Resizing Components ................................................................................................................ 37
Direct Edit .................................................................................................................................. 37
Adding Hyperlinks to Components ............................................................................................. 37
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extracting Standalone Wireframe Artifacts</td>
<td>38</td>
</tr>
<tr>
<td>Embedding Standalone Wireframe Artifacts</td>
<td>38</td>
</tr>
<tr>
<td>Toolbar</td>
<td>39</td>
</tr>
<tr>
<td>Properties View</td>
<td>40</td>
</tr>
<tr>
<td>Outline View</td>
<td>41</td>
</tr>
<tr>
<td>Axiom Rules Language</td>
<td>42</td>
</tr>
<tr>
<td>Introduction</td>
<td>42</td>
</tr>
<tr>
<td>Axiom Rules Language Templates</td>
<td>43</td>
</tr>
<tr>
<td>Configuring Axiom Rules Language Templates</td>
<td>44</td>
</tr>
<tr>
<td>Creating Axiom Rules Language Artifacts</td>
<td>45</td>
</tr>
<tr>
<td>Understanding Axiom Rules Language</td>
<td>45</td>
</tr>
<tr>
<td>If Statements</td>
<td>46</td>
</tr>
<tr>
<td>Conditional Operators</td>
<td>46</td>
</tr>
<tr>
<td>Set Keyword</td>
<td>46</td>
</tr>
<tr>
<td>Validate Keyword</td>
<td>46</td>
</tr>
<tr>
<td>Using Keyword</td>
<td>47</td>
</tr>
<tr>
<td>Comments</td>
<td>48</td>
</tr>
<tr>
<td>Axiom Rules Language Editor</td>
<td>48</td>
</tr>
<tr>
<td>Content Assist</td>
<td>48</td>
</tr>
<tr>
<td>Errors</td>
<td>48</td>
</tr>
<tr>
<td>Navigate to a Referenced Artifact</td>
<td>49</td>
</tr>
<tr>
<td>Linking</td>
<td>50</td>
</tr>
<tr>
<td>Creating Link Templates</td>
<td>50</td>
</tr>
<tr>
<td>Modifying Link Style</td>
<td>51</td>
</tr>
<tr>
<td>Creating Links with the Linking Surface</td>
<td>51</td>
</tr>
<tr>
<td>Adding Artifacts</td>
<td>51</td>
</tr>
<tr>
<td>Adding External URLs</td>
<td>52</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Deleting Artifacts</td>
<td>52</td>
</tr>
<tr>
<td>Linking Artifacts</td>
<td>52</td>
</tr>
<tr>
<td>Discovering Links</td>
<td>52</td>
</tr>
<tr>
<td>Searching the Linking Surface</td>
<td>53</td>
</tr>
<tr>
<td>Thumbnail Window</td>
<td>54</td>
</tr>
<tr>
<td>Linking Surface Commands</td>
<td>54</td>
</tr>
<tr>
<td>Adding External Artifacts</td>
<td>56</td>
</tr>
<tr>
<td>Creating a File Template</td>
<td>56</td>
</tr>
<tr>
<td>Importing External Artifacts</td>
<td>56</td>
</tr>
<tr>
<td>Viewing and Editing File Artifacts</td>
<td>57</td>
</tr>
<tr>
<td>Viewing Previous Versions</td>
<td>57</td>
</tr>
<tr>
<td>Reports</td>
<td>58</td>
</tr>
<tr>
<td>Reports Perspective</td>
<td>58</td>
</tr>
<tr>
<td>Creating Report Templates</td>
<td>58</td>
</tr>
<tr>
<td>Creating Report Artifacts</td>
<td>59</td>
</tr>
<tr>
<td>Defining Report Data Sets</td>
<td>59</td>
</tr>
<tr>
<td>Laying Out Reports</td>
<td>60</td>
</tr>
<tr>
<td>Exporting Reports</td>
<td>61</td>
</tr>
<tr>
<td>Tree Views</td>
<td>62</td>
</tr>
<tr>
<td>Creating Personal Tree Views</td>
<td>63</td>
</tr>
<tr>
<td>Creating Shared Tree View Artifacts</td>
<td>63</td>
</tr>
<tr>
<td>Administration</td>
<td>65</td>
</tr>
<tr>
<td>User Management</td>
<td>65</td>
</tr>
<tr>
<td>Creating Users</td>
<td>65</td>
</tr>
<tr>
<td>Modifying Users</td>
<td>66</td>
</tr>
<tr>
<td><strong>Deleting Users</strong></td>
<td>66</td>
</tr>
<tr>
<td>System Administrators</td>
<td>67</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>License Management</td>
<td>67</td>
</tr>
<tr>
<td>Purchasing License Keys</td>
<td>67</td>
</tr>
<tr>
<td>Adding License Keys</td>
<td>67</td>
</tr>
<tr>
<td>Monitoring Seat Consumption</td>
<td>68</td>
</tr>
<tr>
<td>Artifact Explorer</td>
<td>69</td>
</tr>
<tr>
<td>Commands</td>
<td>69</td>
</tr>
<tr>
<td>Related Concepts</td>
<td>69</td>
</tr>
<tr>
<td>Artifact Table</td>
<td>70</td>
</tr>
<tr>
<td>Populating and Filtering</td>
<td>70</td>
</tr>
<tr>
<td>Editing Custom Attributes</td>
<td>71</td>
</tr>
<tr>
<td>Hiding Columns</td>
<td>71</td>
</tr>
<tr>
<td>Commands</td>
<td>71</td>
</tr>
<tr>
<td>Discussion</td>
<td>73</td>
</tr>
<tr>
<td>Creating Messages</td>
<td>73</td>
</tr>
<tr>
<td>Replying to Messages</td>
<td>73</td>
</tr>
<tr>
<td>Marking Messages as Read/Unread</td>
<td>73</td>
</tr>
<tr>
<td>Deleting Discussion messages</td>
<td>73</td>
</tr>
<tr>
<td>Commands</td>
<td>74</td>
</tr>
<tr>
<td>Related Concepts</td>
<td>74</td>
</tr>
<tr>
<td>Unread Messages</td>
<td>75</td>
</tr>
<tr>
<td>History</td>
<td>76</td>
</tr>
<tr>
<td>Commands</td>
<td>76</td>
</tr>
<tr>
<td>Related Concepts</td>
<td>76</td>
</tr>
<tr>
<td>Watch List</td>
<td>77</td>
</tr>
<tr>
<td>Configuring the Watch List</td>
<td>77</td>
</tr>
<tr>
<td>Working With the Watch List</td>
<td>77</td>
</tr>
<tr>
<td>Commands</td>
<td>78</td>
</tr>
</tbody>
</table>
Axiom Client System Requirements ............................................................................................................. 79
Operating System ............................................................................................................................................... 79
System Specification .......................................................................................................................................... 79
Customer Support ........................................................................................................................................... 80
Welcome to Axiom

Axiom 2012 is a powerful and easy to use platform where distributed teams can define and manage textual artifacts such as requirements and use cases. Additionally, Axiom allows teams to rapidly build user interface prototypes with our advanced UI wireframe builder. These UI prototypes can then be combined with our proprietary Axiom Rules Language so that application behavior can be defined and validated.

This guide provides an overview of Axiom’s core functionality where you will learn how to:

- **Build a template** that defines the structure of a textual artifact.
- Use a template to **create new textual artifacts**.
- Export your requirements, use cases and other textual artifacts to **Microsoft Word**.
- **Build wireframes** that visually describe user interfaces.
- Use **Axiom Rules Language** (ARL) to strictly define behavioral and validation requirements.
- Create **custom links** between requirements and other artifacts.
- Build and publish reports with our integrated **report builder**.

Before we discuss the details, we will provide a quick introduction to the essential concepts of Axiom 2012.
Concepts

This chapter introduces the core concepts related to Axiom. In this chapter we will:

- Discuss the Axiom client/server architecture.
- Introduce the concept of an artifact.
- Provide an overview of Axiom artifact templates.
- Establish the key concepts regarding artifact lifecycle.

Built for Collaboration

Axiom gives analysts, developers, QA professionals and external stakeholders a common, collaborative platform for building and managing requirements, test cases and UI wireframes:

Axiom provides real-time collaboration. This means that, when a user creates or modifies an artifact, all other stakeholders are instantly notified.

Requirements are Artifacts

In this document we will typically use the word “artifact” to describe an object managed by Axiom. An artifact is a tangible by-product of the design and development of software. Examples of artifacts include:

- Stakeholder requests
- Glossaries
- Source code
- Non-functional requirements
- Use cases
- UML diagrams
- Test plans

Axiom is a platform optimized for defining and managing software requirements; however, because Axiom has a flexible architecture, it can easily be utilized to manage any type of textual artifact that your team might need when developing software.

**Templates Define Artifact Types**

In Axiom, users create templates to define the structure for a particular type of textual artifact. For example, a project administrator might create a “Use Case” template that will be used to create a set of use case artifacts:

![Diagram of a Use Case template and its attributes](image)

Templates define the attributes associated with a type of artifact; therefore, when a template is used to create a new artifact, copies of the template’s attributes are passed to the artifact.

![Diagram of attributes passed to an artifact](image)

See [Artifact Templates](#) for a complete explanation of how to create and use artifact templates.
Axiom Helps You Manage Artifacts

Axiom provides the tools your team needs to manage your project’s requirements, use cases and other textual artifacts. More specifically, Axiom:

- Provides a number of configurable views so that artifacts can be filtered, sorted and grouped.
- Tracks the history of all changes to all artifacts system-wide.
- Gives project owners the ability to set fined-grained permissions for sets of artifacts.
- Allows custom triggers to be added so that users will be notified by email when a change occurs.
- Provides export functionality to Microsoft Word so that artifacts can be shared with external stakeholders.
Logging In

Axiom is an enterprise class requirements management solution where your team’s artifacts are stored in a central location (the Axiom server). To use Axiom, you must first log into the Axiom server:

The login procedure for Axiom users is as follows:

1. Enter the name of the Axiom server in Host name field.
2. Type your Axiom user ID in the User ID field.
3. Enter your Axiom password in the Password field.
4. Click the Login button.

If you are the Axiom server administrator, you will use the user ID that you entered when you installed the Axiom server. If you are not an Axiom server administrator and you don’t know your user ID and password, contact your administrator.

By default, the Axiom server will bind to the name of its host computer; therefore, if you enter the server’s IP address, the login might fail. Please see the Axiom Server Getting Started Guide for more information.

Troubleshooting Connection Problems

Axiom provides an advanced diagnostic tool for troubleshooting connection problems. To run this diagnostic tool, simply select the Connection Wizard link on the Login screen and follow the steps provided by the wizard.
After running the Connection Wizard’s diagnostics, you can click the Send Output to Support button to email your log to Customer Support.
Artifact Templates

Before you can create artifacts in Axiom, you’ll need to create a template. A template is a special type of Axiom object that defines the icon, content type and attributes associated with a type of artifact.

Learn how to use templates with our online tutorial.

Creating a Template

1. In Axiom, right-click on a folder in the Artifact Explorer view.
2. Select New->Template... from the popup menu.
3. When the New Template wizard appears, enter a name for your template in the Name field.
4. Select a content type from the Content Type list.
   For most templates, you’ll want to select Text as the content type.
5. Select the Change Icon... button to change your template’s icon.
6. Click the Next > button to advance to the next page.
7. When the Select Template Context page appears, select the locations in the system where instances of the template can be created.
8. Press the Next > button to continue to the next page.
9. The Template Attributes page allows you to associate custom attributes with your template. There are two ways to add an attribute:
   - **Create a new attribute:**
     1. Select the Create... button to create a new attribute.
     2. When the New Attribute wizard appears, enter a name for your attribute in the Name field.
     3. Select an attribute type from the Type drop down.
     4. Enter an optional description in the Description field.
     5. Click the Next > button to advance to the next page.
     6. Select the initial values for your attribute.
     7. Click the Finish button.
   - **Import an attribute from another template:**
     1. Select the Import... button.
     2. When the Existing Attributes dialog appears, select a template from the Templates list.
     3. Select or more attributes from the Attributes list.
     4. Select the OK to associate the attributes with your template.
10. Click the Finish button to create your template.

Creating Artifacts from Templates

Once you have created a template you can use it to create an artifact:

1. Right-click on location in the Artifact Explorer where you want to place the new artifact.
2. Select New from the popup menu.
3. From the popup submenu, select the name of the template that will be used to create your artifact.
4. Enter the name for the new artifact and click Finish.

Modifying a Template

To modify a template:

1. Locate the template that you wish to modify in Axiom’s Artifact Explorer.
2. Right-click on the template.
3. Select Template Properties… from the popup menu.
4. Use the template properties dialog to change the context, name, icon, and attributes associated with the template.

**Warning:** Removing an attribute from a template will cause the attribute to be removed from all artifacts that are associated with that template.

Locating Templates in the Artifact Explorer

All templates in the Artifact Explorer are adorned with a small “T” icon:

![Template Icon](image)

If you are unable to locate a template in the Artifact Explorer:

1. Locate an artifact that was created from the template that you are seeking.
2. Right-click on the artifact.
3. Click Select Template in Explorer from the popup menu.
Working with Artifacts

In this section, you will learn the basics of how to create, modify and delete Axiom artifacts.

Creating a New Artifact

As we discussed in the section on Axiom Templates, to create an artifact, simply:

1. Right-click on location in the Artifact Explorer where you want to create an artifact.
2. Select New from the context menu.
3. Select the type of artifact that you would like to create from the submenu.
4. Specify the name for the new artifact and click Finish.

You can also create a new artifact by select File->New Artifact or Template from the menu bar.

Deleting Artifacts

To delete artifacts from the Artifact Explorer, select one or more artifacts and press the DELETE key on your keyboard. You can also delete artifacts by selecting Edit->Delete from the menu bar, or Delete from context menu of the Artifact Explorer.

Copying Artifacts

In Axiom, you can quickly make copies of one or more artifacts:

1. Right-click on an artifact in the Artifact Explorer.
2. Select Copy from the context menu.
3. Right-click on the artifact that is to be the parent of the copied artifact.
4. Select Paste from the context menu.
5. Once you select Paste, you will be prompted to copy the descendants of the copied artifact (if there are any descendants.)

Artifacts can also be copied by selecting Edit->Copy and Edit->Paste from the main menu bar or by selecting CTRL + C and CTRL + V on your keyboard.

Moving Artifacts

The quickest way to move or reorder artifacts within the Artifact Explorer is to simply drag-and-drop artifacts from one location to another:
You can also move artifacts by:

1. Selecting one or more artifacts in the Artifact Explorer.
2. Right-click and select Cut from the context menu.
1. Right-click on another artifact.
2. Select Paste from the context menu.

Artifacts can also be moved by selecting Edit->Cut and Edit->Paste on the main menu bar or by selecting CTRL + X and CTRL + V on your keyboard.
Editing Artifacts

The content and attributes of an artifact can be edited by double-clicking on the artifact in the Artifact Explorer:

The artifact editor is divided into two sections: A rich text Content Editor for editing the textual content of artifacts and the Attributes Editor for modifying the custom attributes associated with artifacts.

Attributes Editor

The Attributes Editor displays an artifact’s common attributes (ID, last modification date, etc.) and custom attributes.

To hide or display the Attributes Editor, click the Minimize Property View button in upper-right corner:

To toggle the display of the custom attribute descriptions, select the Show Attribute Descriptions button.
Modifying Attributes

To modify an artifact’s attributes:

1. Select an artifact in the **Artifact Explorer**.
2. In the **Attributes Editor**, make the appropriate changes to the artifact’s attributes. Note: When an attribute is modified, the attribute’s label will indicate that a change has occurred by turning red:

   ![Review By:](image)

3. Once you are satisfied with your changes, select the **Save** button from the Axiom toolbar.

Content Editor

Axiom allows you to format your artifact content with a wide range of font faces, colors, and styles. You can also insert tables, hyperlinks and images. Most of Axiom’s rich text formatting options can be found on the Axiom toolbar:

![Content Editor toolbar](image)

The **Content Editor** toolbar contains the following controls:

- **Font** – Opens the **Font** dialog.
- **Clear Formatting** – Removes all formatting from the selected text.
- **Choose a paragraph format** – Changes the paragraph format for the selected text.
- **Choose a font** – Sets the font face of the selected text.
- **Increase Font** – Increases the font size of the selected text.
- **Decrease Font** – Decreases the font size of the selected text.
- **Bold** – Makes the selected text bold.
- **Italic** – Makes the selected text italic.
- **Underline** – Underlines the selected text.
- **Text Color** – Sets the foreground color of the selected text.
- **Highlight Color** – Sets the background color of the selected text.
Bullets – Converts the selected text to a bulleted list.

Numbering – Converts the selected text to a numeric list.

Align Left – Aligns the selected text to the left.

Align Center – Center aligns the selected text.

Align Right – Right aligns the selected text.

Decrease Indent – Decreases the indentation of the selected paragraph(s).

Increase Indent – Increase the indentation of the selected paragraph(s).

Spell Check – Turns on the spell checking feature. When this feature is on, misspelled words will be underlined in red.

Show Boundary Highlighting – When an artifact’s content has embedded artifacts, toggle this button on to show the boundaries of the embedded artifacts.

Adding Tables

To add a table to an artifact’s content:

1. In the editor, select where you want to insert the table.
2. Select Insert->Table from the menu bar.
3. Click the “insert column” buttons ( " or ¦) to insert one or more columns.
4. Press the “insert row” buttons ( ▲ or ▼) to insert one or more rows.
5. Press the “delete” button (□) to delete a row.

Inserting Pictures

To insert an image into an artifact’s content:

1. In the editor, select the location where you would like to place the image.
2. Select Insert->Image from the menu bar.
3. When the Open dialog appears, select an image stored on your computer.

You can also insert images by copying them to the clipboard and then pasting them into the artifact’s content.

Inserting Hyperlinks

You can insert a hyperlink to an external URL or to another Axiom artifact by taking the following steps:

1. Select the location where you want to insert the hyperlink.
2. From the menu bar, select Insert->Hyperlink.
3. When the **Insert Hyperlink** dialog appears, select one of the following tabs:

- **Web Page** – to insert a link to an external URL. When users click on this link, the URL will be opened in the user’s browser.
- **Artifact** – to create a link to another Axiom artifact.
- **Email** – to create a “mailto” link.

4. In the **Text to display** field, enter the text that will be displayed when the hyperlink is shown in the editor. Leave this field blank to display the actual hyperlink text in the editor.

To open a hyperlink in the editor, hold down the **CTRL** key and click the hyperlink.
Artifact Collections

With Axiom you can create documents that contain collections of other artifacts. These collections can be filtered and sorted and will update dynamically as the embedded artifacts change. For example, the following screenshot shows a document that contains a number of high-priority requirements sorted by the name field:

![Artifact Collection Example]

Learn how to use Axiom’s Artifact Collection feature with our [online tutorial](#).

Inserting Artifact Collections

To insert an artifact collection into the content of an artifact:

1. Create (or open) a textual artifact.
2. In the Content Editor, select the location where you want to embed a collection of artifacts.
3. Right-click and select Insert-》Artifacts... from the content menu.
4. To pick which artifacts will be displayed in the collection, define a filter:
   a. When the Artifact Collection Properties dialog appears, select the Filter tab.
   b. Press the Select... button to select the sub-tree of artifacts to include.
   c. When the Select Root Artifact dialog appears, select an artifact from the tree. The descendants of the selected artifact will be included in the collection.
   d. Press the OK button.
   e. If you want to filter the selected artifacts further, press the New button to create a new filter condition.
f. Select a field name, operator and value. For example:

![Artifact Collection Properties](image)

5. To define the collection’s sort order:
   a. Select the **Sort** tab.
   b. Choose a field to sort by from the **Sort items by** dropdown.

6. To define which fields will appear in the inserted content and how these fields will formatted:
   a. Select the **Template** tab.
   b. Type static text into the editor.
   c. Press **CTRL + SPACE** to display a list of artifact fields.
   d. Select a field from the popup list.
   e. Use the formatting toolbar to define the style of the inserted fields and static text.

![Artifact Collection Properties](image)

7. Preview your artifact collection by selecting the **Preview** tab.
8. When you are satisfied with your new artifact collection, press the **OK** button to insert it into your document.
Once an artifact collection has been inserted into the content of an artifact, it can be edited by taking the following steps:

1. Select the artifact collection in the editor.
2. Right-click
3. Select **Artifact Collection Properties...** from the content menu.

### Editing Embedded Artifacts

When you insert an artifact collection, the content of the embedded artifacts is fully editable. Simply select the content and make modifications to the text and formatting. Eventually, when you save the parent artifact, the embedded artifacts will be saved as well.

Depending on how you define your artifact collection, it may be difficult to determine where the editable portions of the embedded artifacts are. If this is the case, simply click the **Show Boundary Highlighting** button to show the location of editable content:

The screenshot above shows the blue and green boundary highlighting for an embedded artifact. The light blue bar indicates a region of an embedded artifact that is “read only” while the light green bar shows a section of editable content.

### Opening Embedded Artifacts

To open an artifact that is embedded in an artifact collection, simply hold down the **CTRL** key and click it. You can also, right-click on the artifact and select **Open Artifact** from the context menu.

This action is especially useful if you need to edit the custom attributes associated with a particular artifact.
Securing Artifacts

Axiom provides a simple, yet powerful, security infrastructure. In this section, we will discuss how to apply access and modification permissions to a sub-tree of artifacts.

Learn how to secure Axiom artifacts with our security tutorial.

To apply security to a sub-tree of artifacts:

1. Locate the root of the sub-tree that you wish to secure. This can be a project, a folder, or any other artifact in the Artifact Explorer.
2. Right-click on the root artifact of the sub-tree.
3. Select Security... from the context menu.
4. When the Permissions dialog appears, select the Add... button to add users.
5. After the Select Users dialog appears:
   a. Select one or more users from the list on the left.
   b. Press the > button to move the users to the list on the right.
   c. Select the OK button.
6. Now that users have been added to the artifact, select a user from the Users list.
7. In the list below, check the permissions to allow or deny.
8. Repeat steps 6 & 7 for the remaining users.
9. If you want to apply these permissions to the entire sub-tree, check the Apply this security to all artifacts under checkbox.
10. Press the OK button.
Creating Microsoft Word Documents

With Axiom, you easily create Microsoft Word (2007 & 2010) documents that contain content from your requirements, use cases and other artifacts. The process for creating a Word Document from Axiom artifacts is as follows:

1. In Axiom, create a Microsoft Office Dataset.
2. In Microsoft Word, create a document that contains an Axiom collection template.
3. Populate your document with data from the Microsoft Office Dataset.

An interactive online tutorial is available for this topic.

Creating a Microsoft Office Dataset

A Microsoft Office Dataset is a collection of data exported by Axiom that can be used to create a Microsoft Word document. You can create a Microsoft Office Dataset by taking the following steps:

1. In Axiom, select File->New Microsoft Office Dataset.
2. After the New Microsoft Office Dataset dialog appears, enter the dataset’s name in the Name field.
3. Press the Select... button to select the sub-tree of artifacts that will be included in the dataset.
4. Optional: Press the New button to create a filter for the dataset.
5. Press the OK button to create the dataset.

Viewing Microsoft Office Datasets

After you create a Microsoft Office Dataset, the Microsoft Office Datasets view will appear:

This view can also be opened by selecting View->Microsoft Office Datasets from Axiom menu bar.

The Microsoft Office Datasets view contains the following columns:

- Name – The name of the dataset.
- Context – The sub-tree of artifacts that is used to populate the dataset.
- Filter – The conditions used to filter the artifacts included in the Context.
- Last Updated – The date the dataset was last refreshed with data from the Axiom server.
Updating Datasets

To refresh a dataset with the latest data from the Axiom server, press the Update Dataset button 🔄. Once a dataset has been updated the Last Updated cell will be set to the current date:

![Last Updated](image)

7/30/11 11:21 AM (48 minutes ago)
7/30/11 12:10 PM (1 second ago)

Editing Datasets

To change the name, context or filter associated with a dataset, double-click on a row in the Microsoft Office Datasets view. This action will open the Edit Microsoft Office Dataset dialog.

Deleting Datasets

To delete a dataset, select a row in the Microsoft Office Datasets view and press the DELETE key on your keyboard, or the Delete button ✗ from the toolbar.
Using Axiom Collection Templates in Microsoft Word

Axiom Collection Templates allow you to define how Axiom content is to be displayed when it is inserted into a Microsoft Word document.

Collection Templates allow you to mix static document content with Axiom data. For example, the following Microsoft Word document contains both static content and an Axiom Collection Template that will later be used to insert several Axiom artifacts:

```
This section defines the high level requirements of the Agiveo Financial Website Redesign project. It will be used as a starting point for:

- Writing test cases.
- Determining when the project is complete.
- Assessing whether or not the project was successful.

The requirements are as follows:
```

<table>
<thead>
<tr>
<th>Template</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Status</td>
</tr>
<tr>
<td>Content</td>
</tr>
<tr>
<td>Template</td>
</tr>
</tbody>
</table>

Inserting Artifact Collection Templates

To insert an Axiom Collection Template into a Microsoft Word document:

1. Open Microsoft Word.
2. Click in the document where you want to insert the Collection Template.
3. On the Axiom tab, click the Insert Collection button:

When the Insert Collection button is pressed, an empty template is inserted into the document:
Edited Artifact Collection Templates

When you insert a collection template into a document, the **Axiom Artifact Collection** pane will appear to the right of the document:

![Axiom Artifact Collection Pane](image)

**Axiom Artifact Collection** pane is used for:

- Selecting the **Microsoft Office Dataset** to use to populate your document.
- Choosing the Axiom artifact field to use when sorting artifacts.
- Inserting Axiom artifact fields into the selected collection template.

To insert an Axiom artifact field into a template simply:

1. Click in the template where you want to insert the field.
2. Select a field name from the **Axiom Artifact Collection** pane.

Within the bounds of a template you can mix Axiom artifact fields with static text and other Microsoft Word objects (such as shapes and pictures):

![Template](image)
You can also use Word’s styles and formatting to design the look of your Axiom artifact data. Simply select a field in the template and apply a style or formatting as you would any other Word element.

**Populating Documents with Axiom Artifacts**

Once you have defined the style and layout of a template, you can populate your document with Axiom artifacts by taking the following steps:

1. On the **Axiom** tab, click the **Populate Document** button:

   ![Populate Document Button](image)

2. When the **Document Close/Reopen** confirmation appears, select **OK**.
3. After your document reopens you will see that it has been populated with Axiom artifacts.

   If you want to change the layout or style of the inserted artifacts or change the dataset used to populate the document, simply select the **Edit Collection Templates** button 🗂️ on the Axiom tab.
Email Triggers

Axiom Professional users can be notified via email when artifacts change. In this chapter we’ll discuss how to create an email trigger and apply that trigger to one or more requirements.

Note: Please see the Axiom Server 2012 Getting Started Guide for information on how to configure your Axiom Server to send email.

Creating Email Triggers

To create an email trigger:

1. Select an artifact in the Artifact Explorer.
2. From Axiom’s menu bar, select Edit->Triggers
3. When the Triggers dialog appears, press the Add… button to add a new trigger.
4. The Add Trigger dialog appears:

![Add Trigger dialog]

5. You now have a decision to make regarding which users will receive email notifications:
   a. Check Users with the following permissions to send email to the users that have a particular security permission. For example, you might use this option to send update emails to all users with “view” permissions for a set of requirements.
   b. Check The users selected in the following attribute checkbox to send update emails to users that have been selected in a custom attribute attached to an artifact. For example, let’s say that your requirements have the following attribute:

![Responsible Users]

- Anthony Rodriguez
- Barbara Hernandez
- Betty Nelson
- Brian Robinson
- Carol Roberts
You could use this option send an email to the selected users when the requirement changes:

6. Once you have selected the users that will be notified, press the OK button.
7. If you want to attach the new trigger to all descendants of the selected artifact, check the Apply this trigger... checkbox:

8. Press the OK button.
Building User Interface Wireframes

User interface wireframes are invaluable for visually communicating the functional requirements, style and layout of an application. With Axiom Professional, you can create and share a UI wireframe in a matter of seconds.

Creating Wireframe Templates

To build one or more wireframe, you must first create a wireframe template:

1. In Axiom, right-click on a folder in the Artifact Explorer view.
2. Select New->Template... from the popup menu.
3. When the New Template wizard appears, enter a name for your wireframe template in the Name field.
4. Select the Wireframe content type from the Content Type list.
5. Click the Next > button to advance to the next page.
6. When the Select Template Context page appears, select the locations in the system where wireframes of this type can be created.
7. Press the Next > button to advance to the next page.
8. The Template Attributes page allows you to associate attributes with your wireframes. For information on how to associate attributes with a template, see the Creating a Template section.
9. Click the **Finish** button to create the wireframe template.

**Creating Wireframe Artifacts**

Once you have defined a [wireframe template](#), you can use it to create wireframe mockup artifacts:

1. Right-click on location in the **Artifact Explorer** where you want to create a wireframe.
2. Select **New** from the popup menu.
3. From the popup submenu, select a wireframe template.
4. Enter a name for your wireframe in the **Name** field.
5. Click the **Next >** button.
6. When the **UI Component Type** page appears, select the user interface that will be the root component of your wireframe. For example, if you are creating a web page wireframe, you will probably want to select a browser component as the root. Likewise, if you are creating a mockup of an application then you may want to start with a dialog component.
7. Press **Finish**.
8. Double-click on the new wireframe artifact to edit it.

**Wireframe Perspective**

Axiom’s **Wireframe** perspective provides a set of views and a layout that is optimized for building user interface wireframes. To switch to the **Wireframe** perspective, click the **Wireframe** button on Axiom’s perspective bar:
Using the Wireframe Editor

Adding Components

The Palette provides instant access to all available wireframe components. Components are organized into groups and can be expanded or collapsed as needed.

To add items to a wireframe you must first select a component from the Palette:

Once you have selected a component, place it in the wireframe by clicking in an open location:

Moving and Aligning Components

As you arrange items on the wireframe, temporary guides will appear to help you align and space your components:

Blue guides indicate that two components have the same X or Y coordinate along an edge. Green guides indicate that the edges of two different components are five pixels apart.
**Resizing Components**

To resize components on the wireframe:

1. Select one or more components on the wireframe’s surface. You can multi-select components by holding the CTRL or SHIFT key and clicking on components.
2. Resize components by dragging a component’s handle.

Note: You can also multi-select components by dragging a marquee selection from the edges of the wireframe:

![Wireframe components being resized](image)

**Direct Edit**

Most wireframe components have a text label that can be edited. The quickest way to edit a component’s label is to select the component and start typing:

![Component label being edited](image)

A component’s name can also be modified in the **Properties view**.

**Adding Hyperlinks to Components**

All wireframe components can be hyperlinked to external wireframes, artifacts or web URL’s. This is especially useful if you want to convey a workflow that involves multiple pages or screens.

To create a hyperlink, simply:

1. Select a component on a wireframe.
2. Press CTRL + K on your keyboard or select the **Hyperlink** button on the Axiom toolbar.
3. When the **Insert Hyperlink** dialog appears, select an existing artifact or enter a URL to an external web page.

To navigate to a hyperlink attached to a wireframe component, simply double-click on the component.
Extracting Standalone Wireframe Artifacts

Often, you will want to use the same group of components in multiple wireframes. For example, in the following wireframe, it would be nice to be able to reuse the selected “Search” component elsewhere:

To extract a component as a stand-alone wireframe artifact:

1. Select the component on the Wireframe Editor to extract.
2. Click the Convert to Standalone button.

When a component is extracted, it will appear as a child of the current wireframe in the Artifact Explorer:

Embedding Standalone Wireframe Artifacts

Once you have created or extracted a stand-alone wireframe artifact, you can import it into other wireframes:

1. In the Wireframe Editor select the Choose component button from the Palette:

2. Click in the Wireframe Editor where you want to insert the component.
3. When the Select Wireframe Artifact dialog appears, select an existing wireframe artifact from the tree.
4. Select the OK button to embed the external component into your wireframe.
**Toolbar**

The wireframe toolbar provides access to the following commands:

- **Undo** – Reverts the most recent change.
- **Redo** – Select this command to redo an action that you undid.
- **Change the font family** – Sets the font face of the selected component’s label.
- **Change the font size** – Sets the font size of the selected component’s label.
- **Bold** – Makes the selected component’s label bold.
- **Italic** – Makes the selected component’s label italic.
- **Underline** – Underlines the label of the selected component.
- **Text Color** – Sets the foreground color of the selected component.
- **Background Color** – Sets the background color of the selected component.
- **Hyperlink** – Creates a hyperlink for the selected wireframe component.
- **Align Left** – Aligns the label of the selected components to the left.
- **Align Center** – Aligns the label of the selected components to the center.
- **Align Right** – Aligns the label of the selected components to the right.
- **Convert to Standalone** – Creates a standalone artifact on the Artifact Explorer tree. For more information, see: [Extracting Standalone Wireframe Artifacts](#).
- **Copy Wireframe as Image** – Captures a screenshot of the wireframe. This action is especially useful if you want share a screenshot of a wireframe through email or some external document.
Align Top – Aligns the top edges of the selected wireframe components.

Align Middle – Aligns the selected wireframe components along their middle.

Align Bottom – Aligns the bottom of the selected components.

Match Width – Makes the selected components the same width.

Match Height – Makes the selected components the same height.

Properties View

The Properties view displays the properties of the selected components. Select a control in the Wireframe Editor to view and edit its properties.

To open the Properties view, select View->Properties from the main menu bar. If you do not see the Properties menu item, switch to the Wireframe Perspective.

When more than one component is selected, all common properties are displayed in the Properties view. When the selected components have different values for a given property the value of the primary selection will be displayed.
Outline View

The Outline view provides a hierarchical view of the relationship between all components in the Wireframe Editor.

To view the Outline view, select **View**->**Outline** from the menu bar. If you do not see the **Outline** menu item, switch to the Wireframe Perspective.

Select one or more components in the Outline view to select the corresponding component in the Wireframe Editor.
Axiom Rules Language

Introduction

Poorly written requirements can often be interpreted by different readers in different ways. Ambiguous requirements lead to confusion for development teams, waste man-hours and will often necessitate a costly rewrite late in the development cycle.

The probability of requirements being misunderstood increases if your software is being developed using an off-shoring model. Developers and testers who do not fully understand the language spoken by a requirement’s author may miss certain nuances that the requirement is meant to convey.

Often times, these requirements will be expressed as business rules that defines or constrains the behavior of the software being developed. Like other requirements, these business rules are susceptible to ambiguous language. For example, consider the following requirement for the “New User” screen of a banking system:

**Address Validation** - When a new user is created he or she must have a valid address. If the address is not valid then an error message should be displayed.

This requirement leaves a number of open questions: Who is creating this new user? Is this an external bank customer or a bank employee? What constitutes a valid address? When will the error message be displayed? Which error message will be displayed?

As we saw in the [previous section](#), Axiom Professional allows you to unambiguously define the structure and layout of a user interface by creating UI wireframes. For example, you could use Axiom to define a “New User” wireframe and an “Error Message” wireframe:
Once you have defined a wireframe, you can utilize Axiom Rules Language (ARL) to unambiguously define validation and behavioral requirements. For example, let’s rewrite the ambiguous “Address Validation” requirement from above using ARL:

```plaintext
when New_User.submitButton is selected
if
  Customer and
  (New_User.address1.length > 100 or
   New_User.address1.text does not start with "one or more numbers")
trigger Invalid_Address_Error.show;
```

In plain English, this ARL snippet states that, “when a customer selects the submit button on the New User screen, show the Invalid Address Error if the address is greater than 100 characters or does not start with at least one number.”

In the following sections, we will:

- Discuss how to create an ARL template and configure it to build rules for wireframes and textual artifacts.
- Give an overview of the ARL language.
- Provide a walkthrough the features of the ARL editor.

### Axiom Rules Language Templates

To write requirements using ARL, you must first create an Axiom Rules Language template:

1. Right-click on a folder in the Artifact Explorer.
2. Select New->Template... from the popup menu.
3. When the New Template wizard appears, enter a name for your ARL template in the Name field.
4. Select the Axiom Rules Language content type from the Content Type list.
5. Click the Next > button to advance to the next page.
6. When the Select Template Context page appears, select the locations in the system where you want to allow ARL artifacts to be created.
7. Press the Next > button to advance to the next page.
8. The Template Attributes page allows you to associate attributes with your ARL. For more information on how to associate attributes with a template, see the Creating a Template section.
9. Click the Finish button to create the ARL template.
Configuring Axiom Rules Language Templates

Before you can create ARL artifacts with an ARL template, you will need to configure the template to reference the names of artifacts in your project. For example, let’s say that you configure your ARL template to point to the “Wireframes”, “Non-Functional Requirements” and “Actors” folders in the Agiveo Financial sample project:

You could then write ARL that references these artifacts by name:

```arxml
when New_User.submitButton is selected
    if
        Customer and
        New_User.emailAddress.text not blank
    validate RFC822;
```

The following image further illustrates the relationship between ARL code and the artifacts it references:
To configure an ARL template to reference artifacts in your project:

1. Locate an ARL template in the Artifact Explorer.
2. Double-click the ARL template to open it in the editor.
3. Place a check mark next to the artifacts that you want your ARL code to reference.
4. Press the Save button on the Axiom toolbar.

Creating Axiom Rules Language Artifacts

Once you have defined an ARL template and configured it to reference artifacts, you can use it to create ARL artifacts:

1. Right-click on location in the Artifact Explorer where you want to create a new ARL artifact.
2. Select New from the popup menu.
3. From the popup submenu, select an ARL template.
4. Enter a name for your ARL artifact in the Name field.
5. Press Finish.

Understanding Axiom Rules Language

A rule written in ARL typically describes an event followed by a change in the system. For example:

```
when New_User.finishButton is selected
trigger Confirmation.show;
```

Here the event is the “Finish” button being pressed on the “New User” screen. The change in the system is that the “Confirmation” screen is displayed.
Note: A rule statement must always end with a semicolon.

If Statements

An if statement can be added to a rule to specify a condition that must be true before the change in the system can occur. To illustrate, let’s add an if statement to the previous example:

```
when New_User.finishButton is selected
if New_User.nameField not blank
trigger Confirmation.show;
```

Now we have a rule that states that the name field must be populated before the confirmation screen can be displayed.

Conditional Operators

The and and or operators can be added to most statements in ARL. For example:

```
when
    New_User.finishButton is selected or
    New_User.nextPageButton is selected
if
    New_User.nameField.text not blank and
    New_User.addressField.text not blank and
    New_User.emailAddressField.text not blank
trigger Confirmation.show;
```

Set Keyword

The set keyword can be used to specify that a property must be set when an event occurs. For example, the following rule defines a requirement that the “name” and “age” fields should be reset when the “Clear” button is selected:

```
when New_User.clearButton is selected
set
    New_User.nameField.text = ""
    New_User.ageField.text = 0;
```

Validate Keyword

The validate keyword can be used to define a requirement for the system at a given point in time. For example:
**Axiom 2012 User Guide**

When `New_User.New_User` is opened

```plaintext
validate

New_User.nameField.maxCharacters = 200
New_User.addressField.maxCharacters = 200
Accessibility;
```

After reading this rule, a tester would understand that, when the “New User” screen is opened, he should only be able to enter a maximum of 200 characters into the name and address fields. Furthermore, the screen must comply with the accessibility requirements for the project.

**Using Keyword**

The **using** keyword defines a scope for a set of rules. The following example defines two rules for a “Login” screen:

```plaintext
using Login
{
  when userID is unfocused
  if userID.text = ""
  trigger userID.focus
  set userID.background = "yellow";

  when userID is closed
  if userID.width not ""
  trigger password.set_focus;
}
```

Because we have utilized the **using** keyword, we do not have to specify that we talking about the Login screen on every line. For example, we don’t have to write:

```plaintext
when Login.userID is unfocused
```

... we can simply write:

```plaintext
when userID is unfocused
```
Comments

ARL provides two ways of adding comments. First, you can use block comments that start with ‘‘/∗’’ and end with ‘∗/’’. For example:

```c
/*
 * When the finish button is selected
 * and the name field is not blank,
 * show the save confirmation.
 */
when New_User.finishButton is selected
if New_User.nameField not blank
trigger Confirmation.show;
```

You can also use end-of-line comments that begin with ‘‘//’’:

```c
when New_User.finishButton is selected
if New_User.nameField not blank
trigger Confirmation.show;
```

Axiom Rules Language Editor

In this section, we will discuss the features of the Axiom Rules Language editor.

Content Assist

In the ARL editor press CTRL + Space to open a list of available code completions:

Use the mouse or the keyboard (Up Arrow, Down Arrow, Page Up, Page Down, Home, or End) to navigate and select lines in the content assist list.

Clicking or pressing the Enter key on a selected line inserts the line into the editor.

Errors

Errors in ARL will be underlined with a red line. Hover over an error to obtain the error message in a tooltip:
Navigate to a Referenced Artifact

To navigate to an artifact referenced in ARL, hold down the CTRL key and hover over the element. When done correctly, the element will become a hyperlink:

```
when Login is submitted

Could not resolve reference to Event 'submitted'.
```

```
when New_User.submitButton is selected

if
    Customer and
    New_User.emailAddress.text not blank

validate RFC922;
```

Click the hyperlink to open the referenced artifact in a separate editor.
Linking

Large scale development projects often require the generation of thousands of requirements, test cases and other textual artifacts. These artifacts are often written collaboratively by domain experts and stakeholders who are geographically distributed.

As these complex projects evolve, teams often face a challenge when trying to understand the relationship between disparate sets of artifacts. When these relationships are not understood, the quality of software often suffers. Decisions are made regarding one set of artifacts without understanding the impact on other artifacts.

Requirement traceability is an important discipline of requirements engineering. With a well defined set of traces, teams can follow the lifecycle of a requirement from its inception, through its development and specification, to its eventual deployment. And, with a high degree of trace fidelity, teams can easily determine where gaps in requirements and other specifications exist.

Axiom is a powerful tool and flexible for building and discovering the relationships between artifacts. Axiom allows you to create not only traces but any type of relationship that makes sense for your project. This means that with Axiom you can, for example, define:

- A “validated by” relationship between a requirement and test case.
- An “extends” relationship between two use cases.
- An “includes” relationship between a set of glossary terms and document.
- A “prototype of” relationship between a use case and UI wireframe.

In Axiom we use the more term “link” to define a semantic relationship between two artifacts.

In this chapter we will describe how to define link templates in Axiom and how to use these templates to create links between your project’s artifacts.

See our comprehensive online tutorial on linking.

Creating Link Templates

As we described in the section on Artifact Templates, almost every object that you create in Axiom is created from a user-defined template. Here is how you create a user-defined template for links:

1. In Axiom, right-click on a folder in the Artifact Explorer view.
2. Select New->Template... from the popup menu.
3. When the New Template wizard appears, enter a name for your link template in the Name field.
4. Select Link 🎥 from the Content Type list.
5. Select the Change Icon... button to change the links icon.
6. Click the Next > button to advance to the next page.
7. When the Select Template Context page appears, select the locations in the system where instances of the link template can be created.
8. Press the Finish button to create the link template.
Modifying Link Style

Every link template has its own set of style attributes. These attributes define how a link will look when it is displayed in Axiom’s Linking Surface. To modify a link’s style attributes:

1. Locate the link template that you wish to modify in the Artifact Explorer.
2. Double-click on the link template to open the editor.
3. Modify the style attributes for the template:

![Link Style Attributes](image)

4. Press the Save button to save your changes.

Creating Links with the Linking Surface

Axiom’s Linking Surface provides an easy way to discover and create links between artifacts.

To display the Linking Surface, select View->Linking Surface from Axiom’s menu bar.

Adding Artifacts

Before you add artifacts to the linking surface, you should make sure the Link with Artifact Explorer button is unchecked. This will prevent the linking surface from refreshing as you select artifacts in the Artifact Explorer.

To add artifacts to the Linking Surface:

1. Click the Add Artifacts button from the toolbar.
2. When the Select Artifacts to Link dialog appears, select one or more artifacts (use either the CTRL or SHIFT key to multi-select artifacts).
3. Press OK.
Note: you can also add artifacts to the linking surface by dragging them from the Artifact Explorer.

Adding External URLs

Axiom allows artifacts to be linked to external URLs. To add a URL to the linking surface:

1. Click the Add Artifacts button 🔄 from the toolbar.
2. When the Select Artifacts to Link dialog appears, select the Web Page tab.
3. Enter a URL in the Address field.
4. Optional: Enter a friendly name for the URL in the Text to Display field.
5. Press OK.

You can also add a URL to the linking surface by simply copying the URL from your browser and pasting it into the Linking Surface.

Deleting Artifacts

To remove artifacts from the Linking Surface, select the artifact(s) and press the DELETE key on the keyboard or the Delete button ✕ on the toolbar.

Linking Artifacts

After you add artifacts to the Linking Surface, Axiom will check to see if there are any templates that can be used to create links between artifacts. Axiom will add these link templates as entries on the Linking Surface’s Palette:

![Palette](image)

If you have previously created a link template and it does not appear in this Palette then you may need to adjust the template’s context. See Modifying a Template for information on how to change a template’s context.

To link artifacts, simply:

1. Select a link type from the Palette.
2. Click on an artifact in the Linking Surface.
3. Click on another artifact in the Linking Surface.
4. Repeat steps 2 and 3 to link additional artifacts.
5. To return to selection mode, click the Select item 🏷 in the Palette.
6. Select the Save button 🌐 on the Linking Surface toolbar to save the links.

Discovering Links

The Linking Surface can be used to discover and browse the links between artifacts.

To discover the links attached to an artifact:
1. Make sure that the Link with Artifact Explorer button is depressed.

2. Select an artifact in the Artifact Explorer. The first level of links for the selected artifact will be displayed in the Linking Surface:

![Image of Linking Surface with artifacts linked](image)

3. Press the Show Hidden Link Count button to show the number of links that are not currently displayed in the Linking Surface. For example, the following requirement has three links that are not being displayed:

![Image of Linking Surface with 3 hidden links](image)

4. To expand the hidden links for an artifact, hold down the ALT key and click on the artifact.

As you expand links to show more artifacts, the Linking Surface may become cluttered and difficult to read. When this happens, simply press CTRL + L or select the Layout command from the Linking Surface’s context menu to arrange the artifacts.

**Searching the Linking Surface**

If you need to quickly find an artifact in the Linking Surface, simply start typing the artifact’s name:
Thumbnail Window

The Linking Surface’s thumbnail view provides an easy way to navigate large graphs of linked artifacts:

To toggle the thumbnail view on/off, press **CTRL + SPACE**.

Linking Surface Commands

The Linking Surface toolbar contains the following commands:

- **Link with Artifact Explorer** – When this button is depressed, the Linking Surface will change as you select artifacts in the Artifact Explorer.

- **Add Artifacts** – Select this button to add one or more artifacts or URL’s to the Linking Surface.

- **Save** – The Save button saves the creation and deletions of artifact links.
Delete—Removes the selected artifacts from the Linking Surface.

Undo — Reverts the most recent change.

Redo — Select this command to redo an action that you undid.

Zoom Out — Select Zoom Out to reduce the view of the Linking Surface. Note: If you have a mouse with a wheel, hold down the CTRL key, and then turn the wheel to zoom in or out.

Zoom In — Select Zoom In to increase the view of the Linking Surface.

Show Hidden Link Count — Displays a count of the number of links that are connected to an artifact that are not currently displayed.

Show Artifact IDs — Depress this button to display the unique ID of artifacts displayed in the Linking Surface.
Adding External Artifacts

Axiom allows you to import external files and manage them like you would any other artifact. This will be especially usefully if, for example:

- You have external requirements in Microsoft Word document.
- You have a set of use case diagrams that you would like to associate with your non-functional requirements stored in Axiom.
- You have a PDF specification from an external stakeholder.

In this section we will discuss how to:

- Create file templates.
- Use file templates to import external files.
- Make and save modification to imported files.

Creating a File Template

As we discussed in the section on artifact templates, all artifacts that are displayed in Axiom’s Artifact Explorer have an associated template; therefore, to import a file into Axiom, you must first have a file template. To create a file template:

1. In Axiom, right-click on a folder in the Artifact Explorer view.
2. Select New->Template… from the popup menu.
3. When the New Template wizard appears, enter a name for your template in the Name field.
4. Select the File content type from the Content Type list.
5. Click the Next > button to advance to the next page.
6. When the Select Template Context page appears, select the locations in the system where instances of the file template can be created.
7. Press the Next > button to advance to the next page.
8. The Template Attributes page allows you to associate attributes with the files that you import. For more information on how to associate attributes with a template, see the Creating a Template section.
9. Click the Finish button to create your file template.

Importing External Artifacts

Once you have defined a file template, you can use the template to import external files:

1. Right-click on location in the Artifact Explorer where you want to import the new artifact.
2. Select New from the popup menu.
3. From the popup submenu, select the name of the file template that will be used to create your artifact.
4. When the file chooser appears, select the file that you wish to import.
5. Press OK.
6. The Select Import Method dialog appears.
7. Choose whether you want to import the entire file into Axiom or simply create a link to the file. The second option is useful if you want to keep the file on your company’s file server but maintain a link to the file inside of Axiom.

8. Press OK to import the file into Axiom (or create a link).

9. The file artifact appears in the **Artifact Explorer**.

### Viewing and Editing File Artifacts

To view and edit a file artifact, simply double-click on it in the **Artifact Explorer**. The file will be opened with the default system editor for your operating system. Once a file is opened, you can modify the file as you would any other file.

Saving modifications to a “fully imported” file artifact is a two-step process: First, save the file in the default editor, then save the associated artifact in Axiom.

### Viewing Previous Versions

You can use Axiom’s **History view** to view previous versions of the selected file artifact:

1. Select **View->History** from Axiom’s menu bar.
2. Press the **Show history for selected artifact** button.
3. After the **History** table is populated, double click on a row to view a particular version of the file artifact.
Reports

Axiom integrates seamlessly with the Eclipse BIRT (Business Intelligence & Reporting Tools) to provide custom reporting on artifact data. BIRT reports are maintained in Axiom and can be exported to a number of formats including: HTML, Microsoft Word and PDF.

Creating a BIRT report in Axiom requires five steps:

1. Creating a report template.
2. Creating a report artifact.
5. Export.

Reports Perspective

Axiom’s Reports perspective provides a set of views and a layout that is optimized for working with reports. To switch to the Reports perspective, simply click the Reports button on Axiom’s perspective bar:

Creating Report Templates
To create a BIRT report in Axiom, you will need to use a report template. If you haven’t already created a report template:

1. Right-click on a folder in the Artifact Explorer view.
2. Select New->Template… from the popup menu.
3. When the New Template wizard appears, enter a name for your report template in the Name field.
4. Select the Report content type from the Content Type list.
5. Click the Next > button to advance to the next page.
6. When the Select Template Context page appears, select the locations in the system where instances of this report template can be created.
7. Press the Next > button to advance to the next page.
8. The Template Attributes page allows you to associate attributes with your report. For more information on how to associate attributes with a template, see the Creating a Template section.
9. Click the Finish button to create your report template.

Creating Report Artifacts

Once you have defined a report template, you can use it to create reports:

1. Right-click on location in the Artifact Explorer where you want to create a report.
2. Select New from the popup menu.
3. From the popup submenu, select a report template.
4. Enter a name for your report in the Name field.
5. Press Finish.

Defining Report Data Sets

Data sets define which Axiom artifacts and fields will be included in your reports. To create a data set:

1. Open a report.
2. Select Data->New Data Set->New Data Set.
3. Once the New Data Set wizard appears, enter a name for your data set in the Data Set Name field.
4. Click the Next > button.
5. On the Axiom Filter page, click the Select… button.
6. When the Select Root Artifact button appears, select an artifact from the tree. Note: The descendants of the selected artifact will be included in the data set.
7. Press the OK button.
8. If you want to apply an additional filter to the selected artifacts then press the New button to create a new filter condition.
9. Once you are satisfied with your filter, press the Finish button.
10. When Edit Data Set dialog appears, select OK.

Once you have defined a data set, you can insert it into a report’s layout:

1. If the Outline view is not visible, open it by selecting View->Outline from the menu bar.
2. Locate your data set in the Outline view.
3. Right-click on the data set and select Insert in Layout from the context menu.
4. Once your dataset has been inserted into the report body you can delete unneeded columns:
   a. In the Outline view, select the Table node from the tree.
   b. In the report body, right-click on the header of the column to remove.
   c. Select Delete from the context menu.

Laying Out Reports

BIRT has a rich set of layout and formatting tools. For a complete reference and walkthrough of this functionality, please consult the Eclipse BIRT documentation.

If you want to create a report with Axiom’s content field then you should be aware that this field may display raw HTML when it is previewed or exported. For example:

...may display like this when previewed:

```html
<!DOCTYPE HTML PUBLIC "~//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head></head>
  <body>
    <h4 style="color: rgb(0, 64, 120);">Goal</h4>
    <span style="font-weight: bold;">Bob</span>
  </body>
</html>
```

To correct this problem, take the following steps:

1. Right-click on the “[Content]” field in the Layout view.
2. Select Delete from the popup menu.
3. Right-click on the empty cell where the “[Content]” field was previously.
4. Select Insert->Dynamic Text from the popup menu.
5. When the Expression Builder dialog is displayed:
   a. Select Available Column Bindings from the Category list.
   b. Select Table from the Sub-Category list.
   c. Double-click on the Content entry in the Double Click to insert list. The Expression Builder dialog should now look like:
6. Click the Preview tab. Your report will now show properly formatted HTML.

Exporting Reports

Once you’ve created a report, you can export it to one of the following formats:

- PDF
- Microsoft Word
- PowerPoint
- Excel
- PostScript

Simply click the dropdown arrow on the View Report button on the toolbar:
Tree Views

Over time projects change as requirements, use cases and other artifacts are added, deleted and moved from one location to the next. For example, consider the following project. In January this project only had a couple of folders and a single artifact:

- Agiveo Financial
  - Business Goals
    - Increase Customer Base
    - Increase Traffic
  - Templates

As the project progressed additional folders where added. Here’s the project in February:

- Agiveo Financial
  - Business Goals
    - Increase Customer Base
    - Increase Profits
    - Increase Traffic
  - Non-Functional Requirements
  - Project Glossary
  - Templates

And finally, here’s the project in March:

- Agiveo Financial
  - Business Goals
    - Increase Customer Base
    - Increase Profits
    - Increase Traffic
    - Obtain Customer Information
    - Reduce Customer Support Cost
    - Turn Visitors Into Customer
  - Non-Functional Requirements
  - Project Glossary
  - Templates
  - Test Cases
  - Use Cases

Axiom Tree Views give you the ability to view your projects at a given point in time. For example, in March you could create a view of the tree for February or for January.

Learn how to use Axiom’s Tree View feature with our online tutorial.
Creating Personal Tree Views

“Personal tree views” are tree views that are only visible on a single computer. To create a personal tree view:

1. Select the Tree Views button 🌟 on the Artifact Explorer toolbar:

2. When the Build Tree View wizard appears, select an artifact from the Available tree on the left:

3. Click the > button to move the selected artifact (and its children) to the Tree View tree on the right.
4. In the Tree View tree on the right, select the root artifact.
5. Select the Date… button to specify a date for the tree view.
6. Once you have selected a date, press the OK button.
7. Select the Next > button to continue.
8. Enter a name for your tree view in the Name field.
9. Press the Finish button to create the tree view.

Once you have created a Tree View it will appear as a view in Axiom. If you close this view, it can be reopened by selecting the dropdown 🎈 next to Tree Views button and clicking on your tree view’s name.

Creating Shared Tree View Artifacts

Another way to define a tree view is to create a shared tree view artifact that resides in the Artifact Explorer with other artifacts.

To create a tree view artifact in Axiom, you will need to use a tree view template. If you haven’t already created a tree view template:

1. Right-click on a folder in the Artifact Explorer view.
2. Select New->Template... from the popup menu.
3. When the New Template wizard appears, enter a name for your tree view template in the Name field.
4. Select the Tree View content type from the Content Type list.
5. Click the Next > button to advance to the next page.
6. When the Select Template Context page appears, select the locations in the system where instances of this tree view template can be created.
7. Press the Next > button to advance to the next page.
8. The Template Attributes page allows you to associate attributes with your tree view. For more information on how to associate attributes with a template, see the Creating a Template section.
9. Click the Finish button to create your tree view template.

Once you have created a tree view template, you can use it to create tree views that will reside in the Artifact Explorer:

1. Right-click on location in the Artifact Explorer where you want to create a tree view.
2. Select New from the popup menu.
3. From the popup submenu, select a tree view template.
4. Enter a name for your tree view in the Name field.
5. When the Build Tree View page appears, select an artifact from the Available tree on the left.
6. Click the > button to move the selected artifact (and its children) to the Tree View tree on the right.
7. In the Tree View tree on the right, select the root artifact.
8. Select the Date... button to specify a date for the tree view.
9. Once you have selected a date, press the OK button.
Administration

In this section we will discuss how to use the Axiom client to maintain users and license keys.

User Management

The Axiom server can be configured to obtain users from your companies LDAP enabled directory server (ActiveDirectory, OpenLDAP, etc.). You can also bypass this configuration and manage users directly in the Axiom server. In this section, we will discuss Axiom’s internal user management feature. For more information on how the Axiom server’s user management feature can be configured, please see the Axiom Server Getting Started Guide.

If you are using Axiom’s embedded user management feature then you will be able to use the User Management dialog to create, delete and update users:

![User Management dialog]

To open the User Management dialog, select Administration->Users... from Axiom’s menu bar.

**Note:** The Administration menu will only appear if the current user is a System Administrator. Furthermore, the Administration->Users menu will only appear if you are using Axiom’s embedded user management feature.

Creating Users

To add a user to the Axiom system:

1. From the User Management dialog, select the Add... button. The New User dialog appears:
2. Enter a unique ID for the user in the **User ID** field.
3. Enter the user’s full name and email address in the **Display Name** and **Email Address** fields respectively.
4. Optional: Check the **System Administrator** checkbox to make the user an Axiom System Administrator.
5. Enter identical temporary passwords in the **Password** and **Confirm Password** fields.
6. Press the **OK** button to create the new user in the system.

**Note:** After the new user logs in for the first time with a temporary password he should select **Edit -> Change Password** from Axiom’s menu bar to change his password.

**Modifying Users**

To modify an Axiom user:

1. Select **Administration->Users...** from the menu bar.
2. Select the Axiom user to modify.
3. Press the **Modify...** button.
4. When the **Edit User** dialog appears, modify the appropriate fields.
5. Press the **OK** button to save the changes.

**Deleting Users**

To delete an Axiom user:

1. Select **Administration->Users...** from the menu bar.
2. Select the Axiom user to delete.
3. Press the **Delete...** button.
4. When the **Delete User** confirmation dialog appears, select the **Yes** button to delete the user from the system.

**Note:** After a user is deleted from the system, the user will no longer be able to login; however, the user’s unique ID and history will be retained. For example, if a user creates a discussion message then the message will remain after the user is deleted.
System Administrators

Axiom System Administrators have “root” or “super user” privileges within the Axiom system. This means that these users can:

- Create, delete and modify other user accounts.
- View and modify all artifacts in the system.
- See special system folders in the Artifact Explorer such as the Deleted Artifacts folder.

License Management

If you are using (or wish to use) the functionality provided by Axiom Professional, then you will need to use the License Management dialog to maintain your Axiom Professional license keys:

To open the License Management dialog, select Administration->License Keys... from Axiom’s menu bar.

Axiom Professional uses a concurrent license management scheme. This means that every time a user logs into the Axiom server a single license “seat” is consumed. Likewise, when a user closes the Axiom client a license seat is released.

Purchasing License Keys

To obtain a license for Axiom Professional or to add additional seats, select the Purchase Licenses... button or go to http://www.iconcursoftware.com/trial.html.

Adding License Keys

To enter a new license key:

1. Select the Add... button from License Keys tab on the License Management dialog.
2. When the New License Key dialog appears, paste your license key in the License Key field.
3. Press OK to add the license key.
**Monitoring Seat Consumption**

Axiom administrators can monitor the consumption and release of seats by selecting the **Seat Usage** tab on the **License Management** dialog:

The **User** column shows the users that are consuming license seats.

The **Seat Refreshed** column shows the last time the corresponding user performed an action that refreshed the seat. If a user closes the Axiom client or stops interacting with the user interface then the user will be removed from this list.
Artifact Explorer

The Artifact Explorer view provides a hierarchical view of Axiom artifacts. From this view you can create, delete and reorder artifacts:

![Artifact Explorer screenshot]

Commands

The Artifact Explorer toolbar contains a number of common commands:

- **Refresh** - Click the refresh button to reload the entire artifact explorer tree.
- **Show Artifact ID** – Shows or hides the unique ID for artifacts.
- **Favorite Tree Views** – A drop down menu for creating, organizing and selecting Tree Views. For more information, see Tree Views.
- **Filter** – Select this button to apply a filter to the Artifact Explorer based on artifact type.
- **Go Into** – The Go Into button to focus the Artifact Explorer on the selected artifact and its children.
- **Back** – Becomes enabled when the Go Into button is used to focus on a sub-tree of artifacts. The Back button returns the focus to the larger tree of artifacts.
- **Home** – Shows all artifacts in the Artifact Explorer.

Related Concepts

- Working with Artifacts
Artifact Table

The Artifact Table view provides a tabular view of Axiom artifact data:

![Artifact Table](image)

Learn how to use the Artifact Table with our interactive Artifact Table tutorial.

To display the Artifact Table view, select View->Artifact Table from the Axiom menu bar.

Populating and Filtering

When opened, the Artifact Table view will initially be empty. To view artifact data, you will need to define a filter:

1. Click the Edit Filters button on the Artifact Table’s toolbar.
2. When the Edit Filters dialog appears, press the Select... button to select a sub-tree of artifacts to filter.
3. If you want to include all artifacts in the selected sub-tree, press the OK button to return to the Artifact Table view; otherwise, click the New button to add a new filter condition.
4. Click the first row in the Attributes column to select an attribute:

![Attribute Selection](image)

5. Select an attribute from the attribute list.
6. Click the first row in the Operator column:

![Operator Selection](image)

7. Select an operator from the list.
8. Click the first row in the Value column:
9. Select or enter a value.
10. Add additional conditions or select the OK button to apply the filter.

**Editing Custom Attributes**

The Artifact Table view can be a powerful tool for modifying the custom attributes of Axiom artifacts. Simply select one or more rows and double click on the cell to be edited:

Once modified, cells will be highlighted:

To save your changes, select the Save button from the toolbar. To revert your changes, select the Refresh button.

**Hiding Columns**

To hide Artifact Table columns, select the View drop down menu from the toolbar:

**Commands**

The Artifact Table toolbar contains the following commands:

- **Save** – Saves all modifications to the Artifact Table.
**Refresh** – Discards all changes and rebuilds the **Artifact Table**.

**Filter** – Click the **Filter** button to select a sub-tree of artifacts and apply a filter.

**Open selected artifact** – Opens the content of the selected artifact in the **Content Editor**.

**Select artifact in Artifact Explorer** – Selects the selected artifact in the **Artifact Explorer**.
Discussion

Users can discuss and provide feedback on Axiom artifacts by utilizing the Discussion view.

Creating Messages

To create a new discussion message:

1. Open the Discussion view by selecting View->Discussion from Axiom’s menu bar.
2. Select the artifact in the Artifact Explorer that you would like to discuss.
3. In the Discussion view, select the New Discussion Message button.
4. When the message window appears, enter a subject and rich text description.
5. Press the OK button to create the message.

Replying to Messages

To reply to a discussion message:

1. Select a discussion message to reply to.
2. In the Discussion view, select the Reply button.
3. When the message window appears, enter a subject and rich text description.
4. Press the OK button to create the reply message.

Marking Messages as Read/Unread

The subjects of all unread messages are displayed as bold in the Discussion view. Messages will be marked as “read” after they have been selected. To mark a discussion as “unread,” right-click on the message and select Mark as Unread.

Deleting Discussion messages
To delete a discussion message, simply select a message and press the DELETE key on your keyboard. Please note however that you can only delete a message that you created which has no replies.

**Commands**

The Discussion view toolbar contains the following commands:

- **New Discussion Message** – Creates a new discussion message for the selected artifact.
- **Reply** – Creates a reply to the selected discussion message.
- **Expand All** – Expands all discussion messages and their replies.
- **Collapse All** – Collapses all reply messages so that only the first level of messages is visible.
- **Go Into** – The Go Into button to focus the Discussion view on the selected message and its replies.
- **Back** – Becomes enabled when the Go Into button is used to focus a discussion message. The Back button returns the focus to the larger view or messages.
- **Home** – Shows all messages in the Discussion view.

**Related Concepts**

- [Unread Messages](#)
Unread Messages

The **Unread Messages** view provides a list of artifacts that have one or more discussion messages that have not been read by the current user.

To view the **Unread Messages** view, select **View→Unread Messages** from Axiom's menu bar.

To view the artifact associated with an unread message, click once on an item in the list. Double-clicking on an item will open the **Discussion View** and select the unread message.
History

The History view provides a tabular view of all versions of an artifact:

![History View](image)

Learn more about the History view with our [interactive tutorial](#).

To view the History view, select View->History from Axiom’s menu bar.

To open a particular version of an artifact, simply double-click on line in the History view. When a previous (non-current) version of an artifact is opened it will not be editable.

Commands

The History view toolbar contains the following buttons:

- **Link with selection** – When selected, the history view will be updated every time you select an artifact in the Artifact Explorer.

- **Show history for selected artifact** – If the Link with selection button is not selected then you can select this button to display the history of the artifact selected in the Artifact Explorer.

Related Concepts

- [Tree Views](#)
Watch List

Ambiguous and confusing language in requirements and other artifacts can often lead uncertainty and wasted man-hours when developing software. To combat this problem, project teams will often define and maintain a glossary of terms.

With Axiom you can create a glossary term template and use it to create glossary term artifacts (see Creating a Template). And, with the Watch List view, you can continually scan your artifacts for the names of these glossary term artifacts:

![Watch List](image)

To learn more about the Watch List consult our interactive tutorial.

Configuring the Watch List

To configure the Watch List, simply point it to a sub-tree of Axiom artifacts by taking the following steps:

1. Open the Watch List by selecting View->Watch List from Axiom’s menu bar.
2. Select the Add Artifacts button from the Watch List toolbar.
3. When the Select Artifact to Watch dialog appears, select a folder or artifact from the tree. For example, you may want to select the folder that contains your project’s glossary terms.
4. Select the OK button.

Note: You can also configure the Watch List by simply dragging artifacts from the Artifact Explorer view.

When the Watch List is properly configured and you open or modify an artifact, the content of the artifact will be scanned for the terms that you selected.

To delete a tree of artifacts from the Watch List, simply select the root of the tree and press the DELETE key on your keyboard.

Working With the Watch List
The Watch List will scan the content of the currently selected artifact; therefore, you only need to open an artifact in the editor to start the scanner.

When an artifact is scanned by the Watch List, the matching terms will be displayed in the Watch List tree. For example, in the screenshot below, the term “Account” was found in an artifact four times:

![Watch List Screenshot](image)

Use the Select Next Match and Select Previous Match buttons to find and highlight the terms in the current artifact’s description.

Double-click on an artifact’s name in the Watch List to view the artifact’s content. This is useful if, for example, you want to view the definition of a glossary term.

**Commands**

The History view toolbar contains the following buttons:

- **Add Artifacts** – Adds a sub-tree of artifacts to be searched for by the Watch List.
- **Select Next Match** – Finds and highlights the next instance of a term in the current artifact content.
- **Select Previous Match** – Finds and highlights the previous instance of a term in the current artifact content.
- **Expand All** – Fully expands the tree of Watch List artifact names.
- **Collapse All** – Collapses the tree of Watch List artifact names.
- **Go Into** – The Go Into button to focus the Watch List on the selected artifact and it descendants.
- **Back** – Expands the scope of the Watch List that was narrowed by the Go Into button.
- **Home** – Shows all artifact names in the Watch List.
Axiom Client System Requirements

The system requirements for the Axiom client are as follows:

Operating System

- Windows 7
- Windows Vista
- Windows XP SP2 or later

System Specification

- GHz CPU (2.2 GHz or higher is recommended)
- 1 GB of system memory (RAM)
- 1 GB available hard disk space
- Screen resolution at 1024 x 768 or higher
Customer Support

Customers who have signed up for Axiom Support and Maintenance, as well as prospective customers who are evaluating Axiom, are eligible for customer support. Our highly trained staff is ready to assist you with any questions or problems that might arise as you install and use the Axiom client.

For customer support contact information, visit: http://www.iconcur-software.com/support.html. If you experience a problem with your Axiom server then please have the following information available when you contact support:

- Client Logs
- Operating System